SGI Indigo R4K Failure – Let out the magic smoke! Burning smell

SGI Indigo Failure

So I *finally* managed to find the keyboard cable for my SGI Indigo on my last trip to Norfolk, VA. This completed what I needed: the 13w3 to VGA cable, the special keyboard and mouse, the system and the keyboard interconnect cable. I humped the thing onto my desk after clearing a bit of space, hooked it up to my monitor, then switched my first SGI on. It powered on! But then came this nasty smell. That’s not good! It did show the clock TOD error, no chime sound (just clicks.)

I originally bought the Indigo from Reputable Systems (Greg Douglas) in the 90s. I was working tech support at the time, living with my parents, and it cost a good chunk of cash — especially by todays standards. Originally it was R3K with a lower level graphics subsystem that I believe could do some hardware 3d acceleration but only 256 colors. I’ll admit when I first started messing with it I was a bit disappointed. It was still sort of slow, but had good audio capabilities and worked well as an X-term. It wasn’t long before MP3 was a new thing and the system couldn’t decode a 128kbps MP3 real time though, it took about 6 minutes for a 4 minute song — so I would have to write it out then write it to minidisc. Creative commons licensed music, of course.

Somewhere along the lines in my SGI fandom I think I ended up with a 9u VME frame that had an ELAN graphics boardset on it. I also ended up with a 2nd SGI Indigo from NASA auctions I used to frequent, one with the faster MIPS R4000 series CPU (R4K.) I remember posting that I was giving away a bunch of hardware including parts from the NASA Indigo, and left it and other stuff behind my office in Virginia Beach for someone else to pick up. But a homeless scrapper got to it first, taking everything metal and leaving plastic shards of laser printers and SGI Indigo (and other equipment) behind. Ugh.

But I held onto my Indigo, not having looked at the CPU cards in a long time. The first thing I did was pull out the CPU card and thought, “man this is bulkier than I remember! What a crazy heatsink for this slow R3000 processor.” But it turns out the R3K board isn’t a R3K board, it’s a R4K board. So then I’m thinking, “Okay so I guess I kept the R4K CPU and the lower graphics board.” But no, the graphics boardset looks stout. So I guess I kept both higher end parts and gave away the old R3K / Entry stuff. Or maybe the Entry graphics was in one of the bigger deskside systems on the frame the Elan came on. I can’t remember.

I remember that the Indigo had two power supply options. One for R3K/Elan graphics and one for R4K. I thought you could use a R4K with entry graphics on the weaker power supply as well. This was a huge issue in my mind since I figured my Indigo had the R3K PSU. I pulled the PSU from Indigo (My Indigo was always named Eggbert from a Super Mario Bros 2 character of similar name that was purple, so from here on it’s Eggbert.) So Eggbert’s PSU turns out to be the R4K model! I opened it up, the capacitors look okay but that really doesn’t say much. No burnt smell inside PSU.

So back to sniffing the circuit boards more. I sniffed and sniffed. Two times over I missed the roasted capacitor on the bottom of the CPU card. I was thinking it had come from the graphics boardset, which sits in the case right next to the bottom of the CPU boardset.

The fried capacitor is C531, and this is near the sound section of the CPU board. No telling what it actually goes to but the lack of the chime sound might have something to do with it. Image slideshow above has a picture of the fried capacitor. Audio sections of computers often use the negative voltages for opamps and DACs where the rest of the computer might not use these voltages, so I might have to check to make sure the power supply isn’t doing something bad on the negative voltage outputs (if it has them.)

In the process of diagnosis I have made a list of all similar style capacitors on the board. I don’t know what is wrong with the machine, but if this style/make of capacitor is degrading from age then the solution should be to replace them. They’re SMD, but pretty large SMD so replacement shouldn’t be TOO bad.

So here is a list of the capacitors I have made so far. I’ve only researched 2 of the 4 with regards to what standard the size is. I have what I believe are DigiKey part numbers for the value that fried and the most common other value (prob used for noise filtering on the power rail.)

I measured the size with a caliper and best guessed on what it equates to in industry.

——————————————

SGI Indigo SMD tantalum caps of the style of the one that burned up:

Top of PCB:
C14, C15, C23, C48 = 47uF,16v
C30 = 33uF, 20v

Bottom of PCB:
C555, C544, C525, C513A, C513B, C578A, C578B, C645A, C645B = 47uF, 16V
C697 = 33uF, 16v
C551 = 33uF, 20V
C507? = 10uF, 10V

C551 is the crispy one

47uF/16v = 7.3mm x 4.42mm : Size 2917 (7343 Metric) / Digikey – 478-1739-1-ND
33uF/20v = 7.44mm x 4.33mm : Size 2917 (7343 Metric) / Digikey – 399-3788-1-ND
10uF/10v = 5.5mm x 3.3mm :
33uF/16v = 7mm x 4.45mm :

———————————————

I will also have to do a battery holder mod since TOD battery is dead.

More updates once replacement caps come in and I replace them.

Leave a Comment

Your email address will not be published. Required fields are marked *